rake db:schema:dump rake aborted! ??

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

rake db:schema:dump rake aborted! ??

Abdel Latif
Hi,
I am following lynda training in my windows 7, I don't know what cause this error :

 rake db:schema:dump

rake aborted!
LoadError: cannot load such file -- mysql2/2.4/mysql2
C:/majid/projTutorials/Lynda/rails/Sites/simple_cms/config/application.rb:7:in `<top (required)>'
C:/majid/projTutorials/Lynda/rails/Sites/simple_cms/Rakefile:4:in `require_relative'
C:/majid/projTutorials/Lynda/rails/Sites/simple_cms/Rakefile:4:in `<top (required)>'
(See full trace by running task with --trace)

Thanks, your help is appreciated.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/rubyonrails-core.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: rake db:schema:dump rake aborted! ??

Prem Sichanugrist
Hi Abdel,

I'm sorry, but this mailing list is reserved for discussion about Ruby on Rails core development (i.e. patch/bug/feature discussions). Please use Ruby on Rails: Talk mailing list or Stack Overflow to ask this type of questions.


For your problem, I googled the error message and this one comes up: https://github.com/brianmario/mysql2/issues/861... I hope this helps.

Thank you,
Prem

On Tue, May 1, 2018 at 1:05 AM, Abdel Latif <[hidden email]> wrote:
Hi,
I am following lynda training in my windows 7, I don't know what cause this error :

 rake db:schema:dump

rake aborted!
LoadError: cannot load such file -- mysql2/2.4/mysql2
C:/majid/projTutorials/Lynda/rails/Sites/simple_cms/config/application.rb:7:in `<top (required)>'
C:/majid/projTutorials/Lynda/rails/Sites/simple_cms/Rakefile:4:in `require_relative'
C:/majid/projTutorials/Lynda/rails/Sites/simple_cms/Rakefile:4:in `<top (required)>'
(See full trace by running task with --trace)

Thanks, your help is appreciated.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/rubyonrails-core.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/rubyonrails-core.
For more options, visit https://groups.google.com/d/optout.