error using direct path url vs ok when navigating by mouse

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

error using direct path url vs ok when navigating by mouse

fugee ohu
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/b71d8e1c-27c5-4a77-bcca-28f9690e3554%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

Colin Law
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLv6FnQndtrNA7Xg0RchA5C6Y_qeh6VeKWL9PMWEjjBK5g%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

fugee ohu


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="aCtArLfHAAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">fuge...@...> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/2d475e34-21f7-4af1-9ed0-0003ac21a887%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

Colin Law
On Fri, 18 Oct 2019 at 19:33, fugee ohu <[hidden email]> wrote:


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

Well that is why it doesn't show the page then.

Colin
 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

fugee ohu


On Friday, October 18, 2019 at 5:07:25 PM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 19:33, fugee ohu <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="2TPNWEDsAAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">fuge...@...> wrote:


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

Well that is why it doesn't show the page then.

Colin
 
It's not a page, it's a link to set_locale path It only changes the locale Does that help 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/d3f94862-c22f-4c46-9178-c78dfddddeaa%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

Ariel Juodziukynas
In reply to this post by Colin Law
Is the link doing a GET request or a POST request? make sure your route matches GET requests too.

El vie., 18 oct. 2019 a las 18:07, Colin Law (<[hidden email]>) escribió:
On Fri, 18 Oct 2019 at 19:33, fugee ohu <[hidden email]> wrote:


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

Well that is why it doesn't show the page then.

Colin
 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAPS3bcAcOgsjyEdG%2BKw-nP_p3WUvmBukM9MBSOvrOuNCTZ8Q1A%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

fugee ohu


On Friday, October 18, 2019 at 9:22:09 PM UTC-4, Ariel Juodziukynas wrote:
Is the link doing a GET request or a POST request? make sure your route matches GET requests too.

El vie., 18 oct. 2019 a las 18:07, Colin Law (<<a href="javascript:" target="_blank" gdf-obfuscated-mailto="oj3nCSf6AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">cla...@...>) escribió:
On Fri, 18 Oct 2019 at 19:33, fugee ohu <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="oj3nCSf6AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">fuge...@...> wrote:


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

Well that is why it doesn't show the page then.

Colin
 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="oj3nCSf6AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonra...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com.


  <li><span class="smaller-text"><%= link_to "한국어", set_locale_path(locale: "ko") %></span>


  get 'set_locale/:locale' => 'world#set_locale', as: 'set_locale'


   def set_locale
    I18n.locale = params[:locale] || "zh-TW"
    respond_to do |format|
        format.html { redirect_to request.referrer }
    end
  end

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

Ariel Juodziukynas
You are using `redirect_to request.referrer` and referrer is nil if you enter the url by hand.

Use `redirect_back fallback: root_path` instead.

El vie., 18 oct. 2019 a las 22:33, fugee ohu (<[hidden email]>) escribió:


On Friday, October 18, 2019 at 9:22:09 PM UTC-4, Ariel Juodziukynas wrote:
Is the link doing a GET request or a POST request? make sure your route matches GET requests too.

El vie., 18 oct. 2019 a las 18:07, Colin Law (<[hidden email]>) escribió:
On Fri, 18 Oct 2019 at 19:33, fugee ohu <[hidden email]> wrote:


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

Well that is why it doesn't show the page then.

Colin
 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com.


  <li><span class="smaller-text"><%= link_to "한국어", set_locale_path(locale: "ko") %></span>


  get 'set_locale/:locale' => 'world#set_locale', as: 'set_locale'


   def set_locale
    I18n.locale = params[:locale] || "zh-TW"
    respond_to do |format|
        format.html { redirect_to request.referrer }
    end
  end

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAPS3bcCG5J5G6wy9KkOz1HVKsh%3D6qNtn7WsM4%3DP5PKgkhbYUjA%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

Ariel Juodziukynas
Sorry, `redirect_back fallback_location: root_path`.

El vie., 18 oct. 2019 a las 23:08, Ariel Juodziukynas (<[hidden email]>) escribió:
You are using `redirect_to request.referrer` and referrer is nil if you enter the url by hand.

Use `redirect_back fallback: root_path` instead.

El vie., 18 oct. 2019 a las 22:33, fugee ohu (<[hidden email]>) escribió:


On Friday, October 18, 2019 at 9:22:09 PM UTC-4, Ariel Juodziukynas wrote:
Is the link doing a GET request or a POST request? make sure your route matches GET requests too.

El vie., 18 oct. 2019 a las 18:07, Colin Law (<[hidden email]>) escribió:
On Fri, 18 Oct 2019 at 19:33, fugee ohu <[hidden email]> wrote:


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

Well that is why it doesn't show the page then.

Colin
 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com.


  <li><span class="smaller-text"><%= link_to "한국어", set_locale_path(locale: "ko") %></span>


  get 'set_locale/:locale' => 'world#set_locale', as: 'set_locale'


   def set_locale
    I18n.locale = params[:locale] || "zh-TW"
    respond_to do |format|
        format.html { redirect_to request.referrer }
    end
  end

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAPS3bcCmb4ew_1LP2GzBUKpJ%2Bm%2BOL69JaDvoZQw1xSNMp%3DCSqw%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

fugee ohu


On Friday, October 18, 2019 at 10:09:09 PM UTC-4, Ariel Juodziukynas wrote:
Sorry, `redirect_back fallback_location: root_path`.

El vie., 18 oct. 2019 a las 23:08, Ariel Juodziukynas (<<a href="javascript:" target="_blank" gdf-obfuscated-mailto="fFa8mbf8AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">arie...@...>) escribió:
You are using `redirect_to request.referrer` and referrer is nil if you enter the url by hand.

Use `redirect_back fallback: root_path` instead.

El vie., 18 oct. 2019 a las 22:33, fugee ohu (<<a href="javascript:" target="_blank" gdf-obfuscated-mailto="fFa8mbf8AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">fuge...@...>) escribió:


On Friday, October 18, 2019 at 9:22:09 PM UTC-4, Ariel Juodziukynas wrote:
Is the link doing a GET request or a POST request? make sure your route matches GET requests too.

El vie., 18 oct. 2019 a las 18:07, Colin Law (<[hidden email]>) escribió:
On Fri, 18 Oct 2019 at 19:33, fugee ohu <[hidden email]> wrote:


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

Well that is why it doesn't show the page then.

Colin
 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium=email&amp;utm_source=footer" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com.


  <li><span class="smaller-text"><%= link_to "한국어", set_locale_path(locale: "ko") %></span>


  get 'set_locale/:locale' => 'world#set_locale', as: 'set_locale'


   def set_locale
    I18n.locale = params[:locale] || "zh-TW"
    respond_to do |format|
        format.html { redirect_to request.referrer }
    end
  end

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="fFa8mbf8AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonra...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com.

Cool Thanks Can you tell me how do I get google to crawl my site in every locale? Just the way I'm doing it now? If not that would mean I should disallow those set_locale links in robots.txt?

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/3a2d0526-9ea5-4adc-bf6f-57b45f1cfc27%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: error using direct path url vs ok when navigating by mouse

fugee ohu
In reply to this post by Ariel Juodziukynas


On Friday, October 18, 2019 at 10:09:09 PM UTC-4, Ariel Juodziukynas wrote:
Sorry, `redirect_back fallback_location: root_path`.

El vie., 18 oct. 2019 a las 23:08, Ariel Juodziukynas (<<a href="javascript:" target="_blank" gdf-obfuscated-mailto="fFa8mbf8AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">arie...@...>) escribió:
You are using `redirect_to request.referrer` and referrer is nil if you enter the url by hand.

Use `redirect_back fallback: root_path` instead.

El vie., 18 oct. 2019 a las 22:33, fugee ohu (<<a href="javascript:" target="_blank" gdf-obfuscated-mailto="fFa8mbf8AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">fuge...@...>) escribió:


On Friday, October 18, 2019 at 9:22:09 PM UTC-4, Ariel Juodziukynas wrote:
Is the link doing a GET request or a POST request? make sure your route matches GET requests too.

El vie., 18 oct. 2019 a las 18:07, Colin Law (<[hidden email]>) escribió:
On Fri, 18 Oct 2019 at 19:33, fugee ohu <[hidden email]> wrote:


On Friday, October 18, 2019 at 5:57:55 AM UTC-4, Colin Law wrote:
On Fri, 18 Oct 2019 at 09:26, fugee ohu <[hidden email]> wrote:
On one of my sites (in production) if I navigate to https://<sitename>/set_locale/ko the browser doesn't load the page but if I'm on the site and I click the  link for that url it works fine I was notified about the error by GSC

You haven't told us what you see in the rails log when you do that.  I am sure you will have looked there before asking.
Not that you have actually asked a question, just told us that you have this interesting occurrence.
Also you haven't told us what is shown in the browser console when it happens.

Colin
 

Both browser console and log say 500 internal server error 

Well that is why it doesn't show the page then.

Colin
 

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium=email&amp;utm_source=footer" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsU1QbNV6i6XQGqbOmAauz-Q9o5wXwx1831%3D1dv4yEcaw%40mail.gmail.com.


  <li><span class="smaller-text"><%= link_to "한국어", set_locale_path(locale: "ko") %></span>


  get 'set_locale/:locale' => 'world#set_locale', as: 'set_locale'


   def set_locale
    I18n.locale = params[:locale] || "zh-TW"
    respond_to do |format|
        format.html { redirect_to request.referrer }
    end
  end

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="fFa8mbf8AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonra...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/401e2df8-b4dd-42fb-9721-39491be9bed3%40googlegroups.com.

That doesn't  redirect or send a response

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/65824491-4388-4a7b-9be3-ba00c033a2e1%40googlegroups.com.