Upgrade an app from rails 4.2 to 5

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Upgrade an app from rails 4.2 to 5

João Bordalo
Hi there,

I'm trying to update a ruby on rails app from 4.2 to 5.0 version.

I'm following this guide https://hashrocket.com/blog/posts/how-to-upgrade-to-rails-5 and when i run $ bundle update rails I have the following error:
"
Bundler could not find compatible versions for gem "activerecord":
  In Gemfile:
    audited-activerecord was resolved to 4.2.2, which depends on
      activerecord (~> 4.0)

    rails (< 5.1, >= 5.0.0.rc2) was resolved to 5.0.0.rc2, which depends on
      activerecord (= 5.0.0.rc2)

"
I'm aware that it might appear some problems related to gems' dependencies, however I can't find out a solution to this problem, since . Can you help me?

Thank you in advance!
João Bordalo

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/a495c69b-caf3-4caa-895e-dbe255dab0ab%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Upgrade an app from rails 4.2 to 5

Frederick Cheung-2
On Tuesday, April 18, 2017 at 9:34:49 PM UTC+1, João Bordalo wrote:

> Hi there,
>
>
> I'm trying to update a ruby on rails app from 4.2 to 5.0 version.
>
>
> I'm following this guide https://hashrocket.com/blog/posts/how-to-upgrade-to-rails-5 and when i run $ bundle update rails I have the following error:
>
> "
>
> Bundler could not find compatible versions for gem "activerecord":
>   In Gemfile:
>     audited-activerecord was resolved to 4.2.2, which depends on
>       activerecord (~> 4.0)
>
>
>     rails (< 5.1, >= 5.0.0.rc2) was resolved to 5.0.0.rc2, which depends on
>       activerecord (= 5.0.0.rc2)
>
>
> "
> I'm aware that it might appear some problems related to gems' dependencies, however I can't find out a solution to this problem, since . Can you help me?

This means that bundler couldn't find a version of the gem compatible with the version of rails you want. In this particular case, it looks like the gem changed name (and is just called audited now) and that recent versions of the gem are compatible with rails 5

Fred.

>
>
> Thank you in advance!
> João Bordalo

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/3a31f0ca-075a-4eac-b256-d7af8ebb1654%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Loading...