Should dalli and redis gems be standard issue (part of "rails new") since they are "require"d?

Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Should dalli and redis gems be standard issue (part of "rails new") since they are "require"d?

Al Snow-2
Should dalli and redis gems be standard issue (part of "rails new") since they are "require"d?
  • activesupport-5.2.3/lib/active_support/cache/redis_cache_store.rb: require "redis"

  • actionpack-5.2.3/lib/action_dispatch/middleware/session/mem_cache_store.rb: require "rack/session/dalli"

  • activesupport-5.2.3/lib/active_support/cache/mem_cache_store.rb: require "dalli"
Also see error message elsewhere in the code
  • actionpack-5.2.3/lib/action_dispatch/middleware/session/mem_cache_store.rb: $stderr.puts "You don't have dalli installed in your application. Please add it to your Gemfile and run bundle install"
  • activesupport-5.2.3/lib/active_support/cache/mem_cache_store.rb: $stderr.puts "You don't have dalli installed in your application. Please add it to your Gemfile and run bundle install"

Thanks,
Al

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-core/339b3e0e-8978-472c-b576-d0e6d8a92f50%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Should dalli and redis gems be standard issue (part of "rails new") since they are "require"d?

Rafael Mendonça França
No. They should not. They are only required if you use one of those cache stores. They are not used by default when you generate a new Rails application.

Sent from my iPhone

On Aug 11, 2019, at 14:04, Al <[hidden email]> wrote:


Should dalli and redis gems be standard issue (part of "rails new") since they are "require"d?
  • activesupport-5.2.3/lib/active_support/cache/redis_cache_store.rb: require "redis"

  • actionpack-5.2.3/lib/action_dispatch/middleware/session/mem_cache_store.rb: require "rack/session/dalli"

  • activesupport-5.2.3/lib/active_support/cache/mem_cache_store.rb: require "dalli"
Also see error message elsewhere in the code
  • actionpack-5.2.3/lib/action_dispatch/middleware/session/mem_cache_store.rb: $stderr.puts "You don't have dalli installed in your application. Please add it to your Gemfile and run bundle install"
  • activesupport-5.2.3/lib/active_support/cache/mem_cache_store.rb: $stderr.puts "You don't have dalli installed in your application. Please add it to your Gemfile and run bundle install"

Thanks,
Al

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-core/339b3e0e-8978-472c-b576-d0e6d8a92f50%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-core/C62202DA-2191-426E-A437-859DC0CD775D%40gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: Should dalli and redis gems be standard issue (part of "rails new") since they are "require"d?

Al Snow-2
After thinking about this, I changed my mind and was going to delete the question. 
THANKS for the thoughtful response.

On Sunday, August 11, 2019 at 2:06:29 PM UTC-4, Rafael França wrote:
No. They should not. They are only required if you use one of those cache stores. They are not used by default when you generate a new Rails application.

Sent from my iPhone

On Aug 11, 2019, at 14:04, Al <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="iorYW8XyEQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">jas...@...> wrote:


Should dalli and redis gems be standard issue (part of "rails new") since they are "require"d?
  • activesupport-5.2.3/lib/active_support/cache/redis_cache_store.rb: require "redis"

  • actionpack-5.2.3/lib/action_dispatch/middleware/session/mem_cache_store.rb: require "rack/session/dalli"

  • activesupport-5.2.3/lib/active_support/cache/mem_cache_store.rb: require "dalli"
Also see error message elsewhere in the code
  • actionpack-5.2.3/lib/action_dispatch/middleware/session/mem_cache_store.rb: $stderr.puts "You don't have dalli installed in your application. Please add it to your Gemfile and run bundle install"
  • activesupport-5.2.3/lib/active_support/cache/mem_cache_store.rb: $stderr.puts "You don't have dalli installed in your application. Please add it to your Gemfile and run bundle install"

Thanks,
Al

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="iorYW8XyEQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonra...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-core/339b3e0e-8978-472c-b576-d0e6d8a92f50%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-core/339b3e0e-8978-472c-b576-d0e6d8a92f50%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-core/339b3e0e-8978-472c-b576-d0e6d8a92f50%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-core/339b3e0e-8978-472c-b576-d0e6d8a92f50%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-core/2d7ac879-12f0-42cc-9ddd-067565daa648%40googlegroups.com.