Running in production mode fails

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Running in production mode fails

He Qi
Hi,

  I am new to rails and not sure if this is the correct place for newbie questions. I'm trying to deploy a small app in rails 5.2.1 to prod. In dev mode (-e development) it works but in prod mode (-e production) it throws error (see bottom). The only change I made after running rails new app is add a  local "gems" folder and add below code to Gemfile:

path './gems' do
  gem 'utils'
  gem 'dsl'
end

The rails version is 5.2.1 and ruby 2.3.0 on win7 64bit. Could anyone help or redirect me to the correct forum? Thank you in advance.

Regards,
He Qi

C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cac
he/core_ext/active_support.rb:74:in `block in load_missing_constant': uninitiali
zed constant ActiveStorage::SetBlob (NameError)
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/active_support.rb:8:in `without_bootsnap_cache'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/active_support.rb:74:in `rescue in load_missing_constan
t'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/active_support.rb:57:in `load_missing_constant'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/activestorage-5.2.1/app/cont
rollers/active_storage/blobs_controller.rb:8:in `<class:BlobsController>'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/activestorage-5.2.1/app/cont
rollers/active_storage/blobs_controller.rb:7:in `<top (required)>'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/kernel_require.rb:21:in `require'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap
_lfi'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/loaded_features_index.rb:65:in `register'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/kernel_require.rb:29:in `require'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/activesupport-5.2.1/lib/acti
ve_support/dependencies/interlock.rb:14:in `block in loading'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/activesupport-5.2.1/lib/acti
ve_support/concurrency/share_lock.rb:151:in `exclusive'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/activesupport-5.2.1/lib/acti
ve_support/dependencies/interlock.rb:13:in `loading'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/active_support.rb:46:in `block in require_or_load'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/active_support.rb:16:in `allow_bootsnap_retry'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/active_support.rb:45:in `require_or_load'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/bootsnap-1.3.2/lib/bootsnap/
load_path_cache/core_ext/active_support.rb:80:in `depend_on'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-5.2.1/lib/rails/eng
ine.rb:478:in `block (2 levels) in eager_load!'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-5.2.1/lib/rails/eng
ine.rb:477:in `each'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-5.2.1/lib/rails/eng
ine.rb:477:in `block in eager_load!'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-5.2.1/lib/rails/eng
ine.rb:475:in `each'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-5.2.1/lib/rails/eng
ine.rb:475:in `eager_load!'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-5.2.1/lib/rails/eng
ine.rb:356:in `eager_load!'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-5.2.1/lib/rails/app
lication/finisher.rb:69:in `each'
        from C:/Ruby23-x64/lib/ruby/gems/2.3.0/gems/railties-5.2.1/lib/rails/app
lication/finisher.rb:69:in `block in <module:Finisher>'

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/7b624a1a-be08-4610-926c-de2ad1a75bb5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.