Re: Rails Gem Not Installing Properly?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Rails Gem Not Installing Properly?

Jim Jeffers
I setup a symbolic link which fixed my command line issues -- pardon me for my lack of linux knowledgability.  But rails itself still isn't acting right on the server:

[root@hotaces httpdocs]# rails demo
/usr/local/bin/rails: line 1: min_release: command not found
/usr/local/bin/rails: line 2: ruby_release: command not found
/usr/local/bin/rails: line 22: syntax error: unexpected end of file

I think it has to do with Rails not installing properly:
[root@hotaces httpdocs]# gem install rails
Attempting local installation of 'rails'
Local gem file not found: rails*.gem
Attempting remote installation of 'rails'
Successfully installed rails-1.0.0

Is there a more specific way I can install rails or reinstall rails?  It doesn't install like this on my local systems.

----------------------------------------

Jim Jeffers

"A trustworthy individual."

www.DontTrustThisGuy.com

(480) 235-5201


On Dec 15, 2005, at 4:06 PM, Jim Jeffers wrote:

Hey guys,
I get a very strange behavior when I attempt to install the Rails gem on my server:

[root@hotaces local]# gem install rails --remote
Attempting remote installation of 'rails'
Successfully installed rails-1.0.0

Normally it asks if I want to include dependencies etc. etc.  This appears to be instant but then when I try to use the rails command it is not there.  I also cannot locate rails on the system... hmm...

----------------------------------------
Jim Jeffers
"A trustworthy individual."
www.DontTrustThisGuy.com
(480) 235-5201

_______________________________________________
Rails mailing list


_______________________________________________
Rails mailing list
[hidden email]
http://lists.rubyonrails.org/mailman/listinfo/rails