Quantcast

I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

I got error xmlrpc-0.3.0 requires ruby version >= 2.3

eben sinaga
Hi

I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?

Thank you

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Edsil Basadre
What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
Hi

I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?

Thank you

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAPmpWecq84jhacjeU5DL1MYxAixsg6cJdHntKnGaaRcK9mpPZw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

eben sinaga
Thank you, I got finished about it. 

On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre wrote:
What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="2VgK4SOKAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">ebenpe...@...> wrote:
Hi

I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?

Thank you

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="2VgK4SOKAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonrails-ta...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="2VgK4SOKAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonra...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Edsil Basadre
Great! So, how did you solved it?
On Mon, 1 May 2017 at 9:35 PM, eben sinaga <[hidden email]> wrote:
Thank you, I got finished about it. 


On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre wrote:
What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
Hi

I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?

Thank you

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAPmpWeeFBMnxoq9FMQAo5UMnRoS-6r%3DzUP5y3VWMm6m%2B%2Bik79A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Simon Fisher
Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I'm not sure how to downgrade the gem and I can't upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?

--- GEM FILE ---

source 'https://rubygems.org'

gem 'rails',                    '5.0.0.1'
gem 'puma',                     '3.4.0'
gem 'sass-rails',               '5.0.6'
gem 'uglifier',                 '3.0.0'
gem 'coffee-rails',             '4.2.1'
gem 'jquery-rails',             '4.1.1'
gem 'turbolinks',               '5.0.1'
gem 'jbuilder',                 '2.4.1'
gem 'bootstrap-sass',           '3.3.6'
gem 'carrierwave',              '0.11.2'
gem 'mini_magick',              '4.5.1'
gem 'fog',                      '1.38.0'
gem 'bcrypt',                   '3.1.11'
gem 'faker',                    '1.6.3'
gem 'will_paginate',            '3.1.0'
gem 'bootstrap-will_paginate',  '0.0.10'

group :development, :test do
  gem 'sqlite3', '1.3.11'
  gem 'byebug',  '9.0.0', platform: :mri
end

group :development do
  gem 'web-console',           '3.1.1'
  gem 'listen',                '3.0.8'
  gem 'spring',                '1.7.2'
  gem 'spring-watcher-listen', '2.0.0'
end

group :test do
  gem 'rails-controller-testing', '0.1.1'
  gem 'minitest-reporters',       '1.1.9'
  gem 'guard',                    '2.13.0'
  gem 'guard-minitest',           '2.4.4'
end

group :production do
  gem 'pg', '0.18.4'
end

# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]

On Monday, 1 May 2017 21:36:43 UTC+8, Edsil Basadre wrote:
Great! So, how did you solved it?
On Mon, 1 May 2017 at 9:35 PM, eben sinaga <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="KC6vi803AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">ebenpe...@...> wrote:
Thank you, I got finished about it. 


On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre wrote:
What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
Hi

I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?

Thank you

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
To post to this group, send email to [hidden email].

To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com?utm_medium=email&amp;utm_source=footer" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="KC6vi803AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonrails-ta...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="KC6vi803AAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonra...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/112f72f9-de21-47a7-9521-afdd24b965a0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Frederick Cheung-2
On Monday, May 1, 2017 at 5:42:22 PM UTC+1, Simon Fisher wrote:
> Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I'm not sure how to downgrade the gem and I can't upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?
>

It's probably a dependency of one of your dependencies (you can see these in your Gemfile.lock).

Heroku should pick the ruby version specified in either you Gemfile or your .ruby-version file. Amy relatively recent version of ruby should be absolutely fine (see https://devcenter.heroku.com/articles/ruby-support#ruby-versions for their supported version policy)

Fred

>
> --- GEM FILE ---
>
>
>
> source 'https://rubygems.org'
>
>
> gem 'rails',                    '5.0.0.1'
> gem 'puma',                     '3.4.0'
> gem 'sass-rails',               '5.0.6'
> gem 'uglifier',                 '3.0.0'
> gem 'coffee-rails',             '4.2.1'
> gem 'jquery-rails',             '4.1.1'
> gem 'turbolinks',               '5.0.1'
> gem 'jbuilder',                 '2.4.1'
> gem 'bootstrap-sass',           '3.3.6'
> gem 'carrierwave',              '0.11.2'
> gem 'mini_magick',              '4.5.1'
> gem 'fog',                      '1.38.0'
> gem 'bcrypt',                   '3.1.11'
> gem 'faker',                    '1.6.3'
> gem 'will_paginate',            '3.1.0'
> gem 'bootstrap-will_paginate',  '0.0.10'
>
>
> group :development, :test do
>   gem 'sqlite3', '1.3.11'
>   gem 'byebug',  '9.0.0', platform: :mri
> end
>
>
> group :development do
>   gem 'web-console',           '3.1.1'
>   gem 'listen',                '3.0.8'
>   gem 'spring',                '1.7.2'
>   gem 'spring-watcher-listen', '2.0.0'
> end
>
>
> group :test do
>   gem 'rails-controller-testing', '0.1.1'
>   gem 'minitest-reporters',       '1.1.9'
>   gem 'guard',                    '2.13.0'
>   gem 'guard-minitest',           '2.4.4'
> end
>
>
> group :production do
>   gem 'pg', '0.18.4'
> end
>
>
> # Windows does not include zoneinfo files, so bundle the tzinfo-data gem
> gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]
> On Monday, 1 May 2017 21:36:43 UTC+8, Edsil Basadre  wrote:
> Great! So, how did you solved it?
>
>
> On Mon, 1 May 2017 at 9:35 PM, eben sinaga <[hidden email]> wrote:
>
> Thank you, I got finished about it. 
>
>
> On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre  wrote:
>
> What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
>
>
>
>
> On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
>
>
>
>
> Hi
>
>
> I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?
>
>
> Thank you
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
>
>
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
>
>
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Edsil Basadre
Frederick is correct, it is a dependency.

On Tue, May 2, 2017 at 12:47 AM, Frederick Cheung <[hidden email]> wrote:
On Monday, May 1, 2017 at 5:42:22 PM UTC+1, Simon Fisher wrote:
> Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I'm not sure how to downgrade the gem and I can't upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?
>

It's probably a dependency of one of your dependencies (you can see these in your Gemfile.lock).

Heroku should pick the ruby version specified in either you Gemfile or your .ruby-version file. Amy relatively recent version of ruby should be absolutely fine (see https://devcenter.heroku.com/articles/ruby-support#ruby-versions for their supported version policy)

Fred
>
> --- GEM FILE ---
>
>
>
> source 'https://rubygems.org'
>
>
> gem 'rails',                    '5.0.0.1'
> gem 'puma',                     '3.4.0'
> gem 'sass-rails',               '5.0.6'
> gem 'uglifier',                 '3.0.0'
> gem 'coffee-rails',             '4.2.1'
> gem 'jquery-rails',             '4.1.1'
> gem 'turbolinks',               '5.0.1'
> gem 'jbuilder',                 '2.4.1'
> gem 'bootstrap-sass',           '3.3.6'
> gem 'carrierwave',              '0.11.2'
> gem 'mini_magick',              '4.5.1'
> gem 'fog',                      '1.38.0'
> gem 'bcrypt',                   '3.1.11'
> gem 'faker',                    '1.6.3'
> gem 'will_paginate',            '3.1.0'
> gem 'bootstrap-will_paginate',  '0.0.10'
>
>
> group :development, :test do
>   gem 'sqlite3', '1.3.11'
>   gem 'byebug',  '9.0.0', platform: :mri
> end
>
>
> group :development do
>   gem 'web-console',           '3.1.1'
>   gem 'listen',                '3.0.8'
>   gem 'spring',                '1.7.2'
>   gem 'spring-watcher-listen', '2.0.0'
> end
>
>
> group :test do
>   gem 'rails-controller-testing', '0.1.1'
>   gem 'minitest-reporters',       '1.1.9'
>   gem 'guard',                    '2.13.0'
>   gem 'guard-minitest',           '2.4.4'
> end
>
>
> group :production do
>   gem 'pg', '0.18.4'
> end
>
>
> # Windows does not include zoneinfo files, so bundle the tzinfo-data gem
> gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]
> On Monday, 1 May 2017 21:36:43 UTC+8, Edsil Basadre  wrote:
> Great! So, how did you solved it?
>
>
> On Mon, 1 May 2017 at 9:35 PM, eben sinaga <[hidden email]> wrote:
>
> Thank you, I got finished about it. 
>
>
> On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre  wrote:
>
> What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
>
>
>
>
> On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
>
>
>
>
> Hi
>
>
> I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?
>
>
> Thank you
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
>
>
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
>
>
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAPmpWeexiLY9d%3DeSp3doBZ3AigxwjK0Jw6r_iiFY%2Bab5SOdy4g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Simon Fisher
Thanks Edsil, Frederick. How did you solve it? Is it as simple as specifying a Ruby version >= 2.3 in your gemfile?

I noticed from the Heroku doco the default ruby version if none is specified in the gemfile is MRI 2.3.4

On Tuesday, 2 May 2017 07:13:03 UTC+8, Edsil Basadre wrote:
Frederick is correct, it is a dependency.

On Tue, May 2, 2017 at 12:47 AM, Frederick Cheung <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="yPxX_kBXAAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">frederic...@...> wrote:
On Monday, May 1, 2017 at 5:42:22 PM UTC+1, Simon Fisher wrote:
> Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I'm not sure how to downgrade the gem and I can't upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?
>

It's probably a dependency of one of your dependencies (you can see these in your Gemfile.lock).

Heroku should pick the ruby version specified in either you Gemfile or your .ruby-version file. Amy relatively recent version of ruby should be absolutely fine (see <a href="https://devcenter.heroku.com/articles/ruby-support#ruby-versions" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fdevcenter.heroku.com%2Farticles%2Fruby-support%23ruby-versions\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE218R4DW9mAKtDRbTIrmz9ZwMbPg&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fdevcenter.heroku.com%2Farticles%2Fruby-support%23ruby-versions\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE218R4DW9mAKtDRbTIrmz9ZwMbPg&#39;;return true;">https://devcenter.heroku.com/articles/ruby-support#ruby-versions for their supported version policy)

Fred
>
> --- GEM FILE ---
>
>
>
> source '<a href="https://rubygems.org" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frubygems.org\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnDOXMwv5NCsokTES3_QhB7ie3VA&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frubygems.org\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnDOXMwv5NCsokTES3_QhB7ie3VA&#39;;return true;">https://rubygems.org'
>
>
> gem 'rails',                    '5.0.0.1'
> gem 'puma',                     '3.4.0'
> gem 'sass-rails',               '5.0.6'
> gem 'uglifier',                 '3.0.0'
> gem 'coffee-rails',             '4.2.1'
> gem 'jquery-rails',             '4.1.1'
> gem 'turbolinks',               '5.0.1'
> gem 'jbuilder',                 '2.4.1'
> gem 'bootstrap-sass',           '3.3.6'
> gem 'carrierwave',              '0.11.2'
> gem 'mini_magick',              '4.5.1'
> gem 'fog',                      '1.38.0'
> gem 'bcrypt',                   '3.1.11'
> gem 'faker',                    '1.6.3'
> gem 'will_paginate',            '3.1.0'
> gem 'bootstrap-will_paginate',  '0.0.10'
>
>
> group :development, :test do
>   gem 'sqlite3', '1.3.11'
>   gem 'byebug',  '9.0.0', platform: :mri
> end
>
>
> group :development do
>   gem 'web-console',           '3.1.1'
>   gem 'listen',                '3.0.8'
>   gem 'spring',                '1.7.2'
>   gem 'spring-watcher-listen', '2.0.0'
> end
>
>
> group :test do
>   gem 'rails-controller-testing', '0.1.1'
>   gem 'minitest-reporters',       '1.1.9'
>   gem 'guard',                    '2.13.0'
>   gem 'guard-minitest',           '2.4.4'
> end
>
>
> group :production do
>   gem 'pg', '0.18.4'
> end
>
>
> # Windows does not include zoneinfo files, so bundle the tzinfo-data gem
> gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]
> On Monday, 1 May 2017 21:36:43 UTC+8, Edsil Basadre  wrote:
> Great! So, how did you solved it?
>
>
> On Mon, 1 May 2017 at 9:35 PM, eben sinaga <[hidden email]> wrote:
>
> Thank you, I got finished about it. 
>
>
> On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre  wrote:
>
> What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
>
>
>
>
> On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
>
>
>
>
> Hi
>
>
> I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?
>
>
> Thank you
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
>
>
>
> To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
>
> To post to this group, send email to [hidden email].
>
>
>
>
> To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
>
> For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.
>
>
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
>
> For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="yPxX_kBXAAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonrails-ta...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="yPxX_kBXAAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonra...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/fe071453-102d-4cd5-9ab8-d7a279c6845b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Edsil Basadre
Hi Simon, have you tried specifying Ruby version on your Gemfile? 

e.g

source "https://rubygems.org"
ruby "2.4.1"

On Tue, May 2, 2017 at 7:50 AM, Simon Fisher <[hidden email]> wrote:
Thanks Edsil, Frederick. How did you solve it? Is it as simple as specifying a Ruby version >= 2.3 in your gemfile?

I noticed from the Heroku doco the default ruby version if none is specified in the gemfile is MRI 2.3.4

On Tuesday, 2 May 2017 07:13:03 UTC+8, Edsil Basadre wrote:
Frederick is correct, it is a dependency.

On Tue, May 2, 2017 at 12:47 AM, Frederick Cheung <[hidden email]> wrote:
On Monday, May 1, 2017 at 5:42:22 PM UTC+1, Simon Fisher wrote:
> Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I'm not sure how to downgrade the gem and I can't upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?
>

It's probably a dependency of one of your dependencies (you can see these in your Gemfile.lock).

Heroku should pick the ruby version specified in either you Gemfile or your .ruby-version file. Amy relatively recent version of ruby should be absolutely fine (see https://devcenter.heroku.com/articles/ruby-support#ruby-versions for their supported version policy)

Fred
>
> --- GEM FILE ---
>
>
>
> source 'https://rubygems.org'
>
>
> gem 'rails',                    '5.0.0.1'
> gem 'puma',                     '3.4.0'
> gem 'sass-rails',               '5.0.6'
> gem 'uglifier',                 '3.0.0'
> gem 'coffee-rails',             '4.2.1'
> gem 'jquery-rails',             '4.1.1'
> gem 'turbolinks',               '5.0.1'
> gem 'jbuilder',                 '2.4.1'
> gem 'bootstrap-sass',           '3.3.6'
> gem 'carrierwave',              '0.11.2'
> gem 'mini_magick',              '4.5.1'
> gem 'fog',                      '1.38.0'
> gem 'bcrypt',                   '3.1.11'
> gem 'faker',                    '1.6.3'
> gem 'will_paginate',            '3.1.0'
> gem 'bootstrap-will_paginate',  '0.0.10'
>
>
> group :development, :test do
>   gem 'sqlite3', '1.3.11'
>   gem 'byebug',  '9.0.0', platform: :mri
> end
>
>
> group :development do
>   gem 'web-console',           '3.1.1'
>   gem 'listen',                '3.0.8'
>   gem 'spring',                '1.7.2'
>   gem 'spring-watcher-listen', '2.0.0'
> end
>
>
> group :test do
>   gem 'rails-controller-testing', '0.1.1'
>   gem 'minitest-reporters',       '1.1.9'
>   gem 'guard',                    '2.13.0'
>   gem 'guard-minitest',           '2.4.4'
> end
>
>
> group :production do
>   gem 'pg', '0.18.4'
> end
>
>
> # Windows does not include zoneinfo files, so bundle the tzinfo-data gem
> gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]
> On Monday, 1 May 2017 21:36:43 UTC+8, Edsil Basadre  wrote:
> Great! So, how did you solved it?
>
>
> On Mon, 1 May 2017 at 9:35 PM, eben sinaga <[hidden email]> wrote:
>
> Thank you, I got finished about it. 
>
>
> On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre  wrote:
>
> What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
>
>
>
>
> On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
>
>
>
>
> Hi
>
>
> I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?
>
>
> Thank you
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
>
>
>
> To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
>
> To post to this group, send email to [hidden email].
>
>
>
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/fe071453-102d-4cd5-9ab8-d7a279c6845b%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAPmpWeco8CY2Bf_ZBhBVUBY-gjywqwkP4%2Bd2ND1dfEEu6CmuFA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Simon Fisher
Indeed, specifying the Ruby version in the gemfile worked. Thanks all for your help.

On Tuesday, 2 May 2017 10:57:55 UTC+8, Edsil Basadre wrote:
Hi Simon, have you tried specifying Ruby version on your Gemfile? 

e.g

source "<a href="https://rubygems.org" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frubygems.org\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnDOXMwv5NCsokTES3_QhB7ie3VA&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frubygems.org\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnDOXMwv5NCsokTES3_QhB7ie3VA&#39;;return true;">https://rubygems.org"
ruby "2.4.1"

On Tue, May 2, 2017 at 7:50 AM, Simon Fisher <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="nGj6RYZjAAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">sij...@...> wrote:
Thanks Edsil, Frederick. How did you solve it? Is it as simple as specifying a Ruby version >= 2.3 in your gemfile?

I noticed from the Heroku doco the default ruby version if none is specified in the gemfile is MRI 2.3.4

On Tuesday, 2 May 2017 07:13:03 UTC+8, Edsil Basadre wrote:
Frederick is correct, it is a dependency.

On Tue, May 2, 2017 at 12:47 AM, Frederick Cheung <[hidden email]> wrote:
On Monday, May 1, 2017 at 5:42:22 PM UTC+1, Simon Fisher wrote:
> Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I'm not sure how to downgrade the gem and I can't upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?
>

It's probably a dependency of one of your dependencies (you can see these in your Gemfile.lock).

Heroku should pick the ruby version specified in either you Gemfile or your .ruby-version file. Amy relatively recent version of ruby should be absolutely fine (see <a href="https://devcenter.heroku.com/articles/ruby-support#ruby-versions" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fdevcenter.heroku.com%2Farticles%2Fruby-support%23ruby-versions\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE218R4DW9mAKtDRbTIrmz9ZwMbPg&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fdevcenter.heroku.com%2Farticles%2Fruby-support%23ruby-versions\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE218R4DW9mAKtDRbTIrmz9ZwMbPg&#39;;return true;">https://devcenter.heroku.com/articles/ruby-support#ruby-versions for their supported version policy)

Fred
>
> --- GEM FILE ---
>
>
>
> source '<a href="https://rubygems.org" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frubygems.org\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnDOXMwv5NCsokTES3_QhB7ie3VA&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Frubygems.org\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHnDOXMwv5NCsokTES3_QhB7ie3VA&#39;;return true;">https://rubygems.org'
>
>
> gem 'rails',                    '5.0.0.1'
> gem 'puma',                     '3.4.0'
> gem 'sass-rails',               '5.0.6'
> gem 'uglifier',                 '3.0.0'
> gem 'coffee-rails',             '4.2.1'
> gem 'jquery-rails',             '4.1.1'
> gem 'turbolinks',               '5.0.1'
> gem 'jbuilder',                 '2.4.1'
> gem 'bootstrap-sass',           '3.3.6'
> gem 'carrierwave',              '0.11.2'
> gem 'mini_magick',              '4.5.1'
> gem 'fog',                      '1.38.0'
> gem 'bcrypt',                   '3.1.11'
> gem 'faker',                    '1.6.3'
> gem 'will_paginate',            '3.1.0'
> gem 'bootstrap-will_paginate',  '0.0.10'
>
>
> group :development, :test do
>   gem 'sqlite3', '1.3.11'
>   gem 'byebug',  '9.0.0', platform: :mri
> end
>
>
> group :development do
>   gem 'web-console',           '3.1.1'
>   gem 'listen',                '3.0.8'
>   gem 'spring',                '1.7.2'
>   gem 'spring-watcher-listen', '2.0.0'
> end
>
>
> group :test do
>   gem 'rails-controller-testing', '0.1.1'
>   gem 'minitest-reporters',       '1.1.9'
>   gem 'guard',                    '2.13.0'
>   gem 'guard-minitest',           '2.4.4'
> end
>
>
> group :production do
>   gem 'pg', '0.18.4'
> end
>
>
> # Windows does not include zoneinfo files, so bundle the tzinfo-data gem
> gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]
> On Monday, 1 May 2017 21:36:43 UTC+8, Edsil Basadre  wrote:
> Great! So, how did you solved it?
>
>
> On Mon, 1 May 2017 at 9:35 PM, eben sinaga <[hidden email]> wrote:
>
> Thank you, I got finished about it. 
>
>
> On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre  wrote:
>
> What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
>
>
>
>
> On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
>
>
>
>
> Hi
>
>
> I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?
>
>
> Thank you
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
>
>
>
> To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
>
> To post to this group, send email to [hidden email].
>
>
>
>
> To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
>
> For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.
>
>
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
>
> For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
To post to this group, send email to [hidden email].
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="nGj6RYZjAAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonrails-ta...@googlegroups.com.
To post to this group, send email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="nGj6RYZjAAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">rubyonra...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/rubyonrails-talk/fe071453-102d-4cd5-9ab8-d7a279c6845b%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/fe071453-102d-4cd5-9ab8-d7a279c6845b%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/rubyonrails-talk/fe071453-102d-4cd5-9ab8-d7a279c6845b%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/rubyonrails-talk/fe071453-102d-4cd5-9ab8-d7a279c6845b%40googlegroups.com.

For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/40b8364f-2420-4f1b-9b47-f266b3db142e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: I got error xmlrpc-0.3.0 requires ruby version >= 2.3

Edsil Basadre
Great! 

On Sat, May 6, 2017 at 12:38 PM, Simon Fisher <[hidden email]> wrote:
Indeed, specifying the Ruby version in the gemfile worked. Thanks all for your help.

On Tuesday, 2 May 2017 10:57:55 UTC+8, Edsil Basadre wrote:
Hi Simon, have you tried specifying Ruby version on your Gemfile? 

e.g

source "https://rubygems.org"
ruby "2.4.1"

On Tue, May 2, 2017 at 7:50 AM, Simon Fisher <[hidden email]> wrote:
Thanks Edsil, Frederick. How did you solve it? Is it as simple as specifying a Ruby version >= 2.3 in your gemfile?

I noticed from the Heroku doco the default ruby version if none is specified in the gemfile is MRI 2.3.4

On Tuesday, 2 May 2017 07:13:03 UTC+8, Edsil Basadre wrote:
Frederick is correct, it is a dependency.

On Tue, May 2, 2017 at 12:47 AM, Frederick Cheung <[hidden email]> wrote:
On Monday, May 1, 2017 at 5:42:22 PM UTC+1, Simon Fisher wrote:
> Hi Edsil, I have the same issue as Edsil and it is because of the Ruby version running on Heroku. Curious thing is that xmlrpc-0.3.0 is not a gem in my gemfile (pasted below) so I'm not sure how to downgrade the gem and I can't upgrade the version of Ruby on Heroku (to my knowledge). Any ideas?
>

It's probably a dependency of one of your dependencies (you can see these in your Gemfile.lock).

Heroku should pick the ruby version specified in either you Gemfile or your .ruby-version file. Amy relatively recent version of ruby should be absolutely fine (see https://devcenter.heroku.com/articles/ruby-support#ruby-versions for their supported version policy)

Fred
>
> --- GEM FILE ---
>
>
>
> source 'https://rubygems.org'
>
>
> gem 'rails',                    '5.0.0.1'
> gem 'puma',                     '3.4.0'
> gem 'sass-rails',               '5.0.6'
> gem 'uglifier',                 '3.0.0'
> gem 'coffee-rails',             '4.2.1'
> gem 'jquery-rails',             '4.1.1'
> gem 'turbolinks',               '5.0.1'
> gem 'jbuilder',                 '2.4.1'
> gem 'bootstrap-sass',           '3.3.6'
> gem 'carrierwave',              '0.11.2'
> gem 'mini_magick',              '4.5.1'
> gem 'fog',                      '1.38.0'
> gem 'bcrypt',                   '3.1.11'
> gem 'faker',                    '1.6.3'
> gem 'will_paginate',            '3.1.0'
> gem 'bootstrap-will_paginate',  '0.0.10'
>
>
> group :development, :test do
>   gem 'sqlite3', '1.3.11'
>   gem 'byebug',  '9.0.0', platform: :mri
> end
>
>
> group :development do
>   gem 'web-console',           '3.1.1'
>   gem 'listen',                '3.0.8'
>   gem 'spring',                '1.7.2'
>   gem 'spring-watcher-listen', '2.0.0'
> end
>
>
> group :test do
>   gem 'rails-controller-testing', '0.1.1'
>   gem 'minitest-reporters',       '1.1.9'
>   gem 'guard',                    '2.13.0'
>   gem 'guard-minitest',           '2.4.4'
> end
>
>
> group :production do
>   gem 'pg', '0.18.4'
> end
>
>
> # Windows does not include zoneinfo files, so bundle the tzinfo-data gem
> gem 'tzinfo-data', platforms: [:mingw, :mswin, :x64_mingw, :jruby]
> On Monday, 1 May 2017 21:36:43 UTC+8, Edsil Basadre  wrote:
> Great! So, how did you solved it?
>
>
> On Mon, 1 May 2017 at 9:35 PM, eben sinaga <[hidden email]> wrote:
>
> Thank you, I got finished about it. 
>
>
> On Sunday, 30 April 2017 15:23:46 UTC+7, Edsil Basadre  wrote:
>
> What is your Ruby version? Based on that error you need to have the version that required for that Gem. So either you upgrade your ruby version or downgrade the gem that requiring the specific version of ruby.
>
>
>
>
> On Sun, 30 Apr 2017 at 3:11 PM, eben sinaga <[hidden email]> wrote:
>
>
>
>
> Hi
>
>
> I got error xmlrpc-0.3.0 requires ruby version >= 2.3 when i deploy to heroku . what should I do ?
>
>
> Thank you
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
>
>
>
> To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
>
> To post to this group, send email to [hidden email].
>
>
>
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/ae91d3a6-4bd9-41b9-8741-2322b52caf44%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.
>
>
>
>
>
>
> --
>
> You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
>
> To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
>
> To post to this group, send email to [hidden email].
>
> To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/25f51776-37a0-4cf4-8aa5-82b83a5d6504%40googlegroups.com.
>
> For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/d7a15994-d6ee-4272-9797-2381c705c031%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-ta...@googlegroups.com.
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/fe071453-102d-4cd5-9ab8-d7a279c6845b%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/40b8364f-2420-4f1b-9b47-f266b3db142e%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAPmpWef%2BKaRUc8o8KbkX2tOUDMS9sNxydJKLUGHj4nempH%2BjFQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Loading...