Bump minimum SQLite version to 3.8 for Rails 6

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Bump minimum SQLite version to 3.8 for Rails 6

Yasuo Honda
Hi,

I'd like to propose that Rails 6 requires SQLite 3.8 or higher.

These OS versions have SQLite 3.8 or higher by default.

- macOS 10.10 (Yosemite) or higher
- Ubuntu 14.04 LTS or higher

There was a similar discussion for Rails 5 two years ago, yes I
requested that one.
https://groups.google.com/forum/#!topic/rubyonrails-core/Mm4ZN_g1RXk

Since two years passed since my previous request, Ubuntu 12.04 LTS
support has been dropped and newer macOS versions have been released.
I think it is good time to bump the minimum version of SQLite for
Rails 6.

Also, bumping SQLite version 3.8 will allow supporting `alter_table`
method for the table with foreign keys by this pull request:

"Disable foreign keys during `alter_table` for sqlite3 adapter"
https://github.com/rails/rails/pull/32865
requires SQLite 3.8 to support `defer_foreign_keys` pragma.

Please review my proposal. I am ready to open a pull request.

Thanks,
--
Yasuo Honda

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/rubyonrails-core.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Bump minimum SQLite version to 3.8 for Rails 6

Yasuo Honda
This proposal has been implemented for Rails 6 by this pull request https://github.com/rails/rails/pull/32923 

Thanks,
--
Yasuo Honda

On Thursday, May 17, 2018 at 8:35:33 PM UTC+9, Yasuo Honda wrote:
Hi,

I'd like to propose that Rails 6 requires SQLite 3.8 or higher.

These OS versions have SQLite 3.8 or higher by default.

- macOS 10.10 (Yosemite) or higher
- Ubuntu 14.04 LTS or higher

There was a similar discussion for Rails 5 two years ago, yes I
requested that one.
<a href="https://groups.google.com/forum/#!topic/rubyonrails-core/Mm4ZN_g1RXk" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/forum/#!topic/rubyonrails-core/Mm4ZN_g1RXk&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/forum/#!topic/rubyonrails-core/Mm4ZN_g1RXk&#39;;return true;">https://groups.google.com/forum/#!topic/rubyonrails-core/Mm4ZN_g1RXk

Since two years passed since my previous request, Ubuntu 12.04 LTS
support has been dropped and newer macOS versions have been released.
I think it is good time to bump the minimum version of SQLite for
Rails 6.

Also, bumping SQLite version 3.8 will allow supporting `alter_table`
method for the table with foreign keys by this pull request:

"Disable foreign keys during `alter_table` for sqlite3 adapter"
<a href="https://github.com/rails/rails/pull/32865" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Frails%2Frails%2Fpull%2F32865\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGIIwLdvJWfPA4B647F_Zppe_GANA&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Frails%2Frails%2Fpull%2F32865\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGIIwLdvJWfPA4B647F_Zppe_GANA&#39;;return true;">https://github.com/rails/rails/pull/32865
requires SQLite 3.8 to support `defer_foreign_keys` pragma.

Please review my proposal. I am ready to open a pull request.

Thanks,
--
Yasuo Honda

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/rubyonrails-core.
For more options, visit https://groups.google.com/d/optout.