* better messages for should[_not] be_nil (Chad Humphries and Rob Sanheim)
* should and should_not accept optional custom message
(suggestion from Rob Sanheim)
* result.should be_nil, "expected result to be nil"
* added 'spec/stubs/cucumber' to plug RSpec's stubbing framework into
* added unstub method to remove a stub mid-example (Scott Taylor). Closes
* add more readable diff when expected and actual are hashes (Ryan Bigg).